chris-busillo avatar image
chris-busillo asked chris-busillo commented

iPhone/Android app not ringing in queue. Skipping over ordered list.

Hi, we have a US account.  I have a queue set up that rings 4 users in a specific order.  It works perfect about half the time.  The rest of the time it will skip over 1 2 or 3 of the users.  The first user are logged into the mobile app on an Android phone.  Users 2 and 3 are logged into iPhones.  The last user is logged into the desktop (Mac) app in the office.  

Many times the desktop app will ring before any of the smart phone apps do.  Its usually happens when the phone is locked.  After the 4th user is rung it wraps back around.  Usually the first person to unlock his phone after the computer rings will get the call.  

Is there something in the app that is setup in correctly or is this a bug?  All the devices are on the same wifi.  The connection here is very good, sound quality is always great, ping times are low and bandwidth is 100/20MB.  Any suggestions?

BTW I have gone individually through every setting and nothing has popped out at me.  The post wrap up time is setup to 0 seconds.


EDIT:All phones are set to ring, no silent vibrate.  Already solved the problem with the Apple Watch on one of the iPhones, the other iPhone has never had an Apple watch attached.
1 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

kim avatar image
kim answered chris-busillo commented
Chris, are those app's running in the background when the phone is locked, or are the apps closed? 

It will skip them if they are on another call, or if their app is closed (not running in the background).

Also, have the users do a hard reboot on their cell phones. 
1 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

chris-busillo avatar image chris-busillo commented ·
Everything is up to date as of today.  I will keep an eye on the problem and call support when it starts acting up again.
1 Like 1 ·
chris-busillo avatar image chris-busillo commented ·
They are open in the background.  We have tried restarting their phones.  The fact that it happens on three different devices on two operating systems makes me lean toward a configuration problem or a bug.  Its hard to troubleshoot since its not consistent.  Today we have user 2 and 3 (both iPhone users) and its worked perfectly.

Thank you for the help.  Let me know if you have any ideas or ways to troubleshoot.
0 Likes 0 ·
kim avatar image kim commented ·
I wouldn't be a "bug" b/c it's happening on different apps (iphone/android).  Have the users make sure the App's are up-to-date. Otherwise, contact support for further troubleshooting. 
0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.