mike avatar image
mike asked mike answered

Mobile App: T-Mobile users unable to make or receive VoIP calls after upgrading to iOS 10.2 (RESOLVED)

T-Mobile users who have recently upgraded to iOS 10.2 may be unable to make or receive calls on the RingCentral mobile app, and get the message "VoIP is Unavailable". 

This is a result of the carrier supplying only the newer IPv6 addresses, instead of a dual IPv4/IPv6address which it usually provides. 

If you are a T-Mobile user and are experiencing this problem please open a support case using the button below and in your case notes please include the details below. Or, contact Telephone or Live Chat here. 

  1. The specific RingCentral user(s) with the T-Mobile device
  2. Copy and paste the following text into the case notes:   Please enable IPv6 Support 

Note:  RingCentral is pushing an update for all users and is expected to be completed by January 13th, 2017. 

1 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

andres-sauceda3880 avatar image
andres-sauceda3880 answered mike commented
I FOUND OUT HOW TO FIX THIS PROBLEM!!!!!! I was one of these users that upgraded to 10.2 and then all of a sudden my ring central app stopped working! (I could take calls as long as I was on Wi-Fi but not when connected to LTE). here is how I fixed it by total surprise actually. So you know here are my devices. iPhone 7 128gig . T Mobile Service. LTE. Once I upgraded to 10.2 I noticed I stopped getting Ring Central calls. My phone would say at the top of the App that it could not connect to the server. Once I was on Wi-Fi my Ring Central app worked fine. Well I made multiple calls to T Mobile and to Ring Central and they both basically blame eachother. This seem weird that it would be T Mobiles fault as my company has 20 employees and the app works fine for them on LTE (T-Mobile) So Just an hour ago I couldn't get a good wifi signal at the coffee shop I was at and I like usual connect my computer to my phone so that it shares the LTE with my Computer. Once in a while I use the Desktop app on the computer. So I thought to myself. Hey Ring Central claims that it's T mobile fault that the mobile app doesn't work. Well hey if that's truly the case then I should NOT be able to use the Desk Top App using my T-Mobile Phone Tethered LTE From my Phone. (IN NON TECH Language - If my laptop wifi is turned OFF and i connect my T Mobile Phone to my Laptop and make sure that my "HOT SPOT" is turned on my iPhone then the Desktop Ring Central App on my computer SHOULD ALSO NOT WORK" Fully expecting the ring central app to not work I tried connecting my phone and turning on the hot spot on my phone. The ring central app on my computer loaded up just fine.... Interesting... SO then I decided to make a test phone call.... BOOM! The test phone call worked from my computer. I about pooped a brick. SO THIS CLEARLY MEANS THAT IT'S NOT A T-MOBILE ISSUE! WHY? BECAUSE RIGHT NOW I'M USING THE DATA FROM MY T MOBILE PHONE TO DRIVE THE PHONE CALLS ON MY LAPTOP. I double checked to make sure I wasn't double connected to any other wifi on my phone or on my laptop. NOPE just good ole TMOBILE LTE. (SUPER fast btw) Okay so next I was like okay so why does it work from my laptop from the T Mobile Hot spot and not from my phone again? So I decided to Try my phone again. GUESS WHAT!!!! ALL OF A SUDDEN MY PHONE COULD MAKE A CALL WITH THE RING CENTRAL APP! WHAT THE CRAP!!! SO the moral of the story is do these simple steps. if your phone says "Can't connect to the Server" using the Mobile App. (T-Mobile) I have no idea about any others. 1. Find your computer that you've had your ring central app loaded on. Make sure ITS OFF WIFI or any other network connection. 2. Connect your iPhone to that exact computer. Make sure the Ring Central App is OPEN on your computer and ready to go. If you have NO WIFI and no networking it shouldn't be able to get online or do anything. 3. Go to settings in your phone. Click on PERSONAL HOTSPOT. Then Click Personal Hot Spot and turn on. IT IS IMPORTANT TO KNOW THAT YOUR COMPUTER WILL NOT ALLOW THE IPHONE HOTSPOT TO WORK IF YOU DON'T HAVE ITUNES ALREADY ON IT. IF YOU DON'T HAVE ITUNES GO BACK AND INSTALL ITUNES FIRST AND TRY AGAIN.' 4. After you have the hotspot on go ahead and reload the Ring Central Aopp on your Computer. 5. once the app opens try making a test call verify by calling out. It should work. 6. After you make a test call That works. Unplug from said computer and open the Mobile app on your phone. 7. make a test call out using ring Central. 8. IT works and then press like to my post here. Maybe even give me a digital hi five. 9. Be annoyed at Ring Central for missing this detail in frustrating customers that need to use the mobile app. 10. Go on with your day and enjoy life.
1 comment
1 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

mike avatar image mike commented ·
Andres Sauceda,   Your account is one that was automatically updated to support the IPv6.  

So... other viewers, I can not confirm that the steps above will work. In either case if you have this issue contact support or reply to this thread and there's a simple checkbox on our end that can enable the service. 


0 Likes 0 ·
mike avatar image
mike answered
Letting you all know that the IPv6 support has been rolled out to production, and the "VoIP Unavailable" problem with T-Mobile users should have been resolved.  

If anyone still has issues with this please contact support and open a ticket for escalation. Thanks!

1 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.